All systems operational

Production Maintenance

Completed
Scheduled for April 11, 2023 at 16:00 – 17:54

Affects

Website
Webshop
Customer Support
Portal
Internal Infrastructure & Services
Battery Testing
Updates
  • Completed
    April 11, 2023 at 17:54
    Completed
    April 11, 2023 at 17:54

    Maintenance has completed successfully.

  • In progress
    April 11, 2023 at 16:00
    In progress
    April 11, 2023 at 16:00

    Maintenance is now in progress

  • Update
    April 11, 2023 at 16:00
    Planned
    April 11, 2023 at 16:00

    We are planning for a scheduled maintenance during that time. Multiple service interruptions can be expected.

  • Planned
    March 27, 2023 at 10:22
    Planned
    March 27, 2023 at 10:22

    This production maintenance window will be on Tuesday April 11, as on Monday is Easter Monday Holiday.