CompletedProduction Maintenance
Status
Resolved after about 2 hours
Started
March 13, 2023 at 17:00
Completed
March 13, 2023 at 18:56
Affects
Battery Testing
Customer Support
Internal Infrastructure & Services
Portal
Webshop
Website
- CompletedMarch 13, 2023 at 18:55
- In progressMarch 13, 2023 at 17:00
- PlannedMarch 13, 2023 at 17:00