Battery Platform Production Upgrades
Scheduled for January 21, 2026 at 19:30 – 20:30
Affects
Battery Testing
Under maintenance from 7:30 PM to 8:30 PM
Completed
January 21, 2026 at 20:30Completed
January 21, 2026 at 20:30Maintenance has completed successfully
In progress
January 21, 2026 at 19:30In progress
January 21, 2026 at 19:30Maintenance is now in progress
Planned
January 21, 2026 at 19:30Planned
January 21, 2026 at 19:30We are planning to upgrade production services related to Battery Testing Platform. Service interruptions can be expected.