Battery Platform Production Upgrades
Scheduled for August 07, 2025 at 19:00 – 20:00
Affects
Battery Testing
Under maintenance from 7:00 PM to 8:00 PM
Completed
August 07, 2025 at 20:00Completed
August 07, 2025 at 20:00Maintenance has completed successfully
In progress
August 07, 2025 at 19:00In progress
August 07, 2025 at 19:00Maintenance is now in progress
Planned
August 07, 2025 at 19:00Planned
August 07, 2025 at 19:00We are planning to upgrade production services related to Battery Testing Platform. Service interruptions can be expected.