Scheduled for June 20, 2025 at 16:00 – 16:18
Affects
Portal
Under maintenance from 4:00 PM to 4:18 PM
Battery Testing
Under maintenance from 4:00 PM to 4:18 PM
- Completed June 20, 2025 at 16:18
- Completed - June 20, 2025 at 16:18- Maintenance has completed successfully. 
 
- In progress June 20, 2025 at 16:00
- In progress - June 20, 2025 at 16:00- Maintenance is now in progress 
 
- Planned June 20, 2025 at 16:00
- Planned - June 20, 2025 at 16:00- Because of an issue with a new version of an underlying platform service detected on our internal services, we will implement measures to prevent unplanned issues on our production system. 
 We are planning for a scheduled maintenance during that time.