Battery Platform Production Upgrades
Scheduled for March 17, 2025 at 19:00 – 19:13
Affects
Battery Testing
Under maintenance from 7:00 PM to 7:13 PM
Completed
March 17, 2025 at 19:13Completed
March 17, 2025 at 19:13Maintenance has completed successfully.
In progress
March 17, 2025 at 19:00In progress
March 17, 2025 at 19:00Maintenance is now in progress
Planned
March 17, 2025 at 19:00Planned
March 17, 2025 at 19:00We are planning to upgrade production services related to Battery Testing Platform. Service interruptions can be expected.